PCTeX Talk Forum Index PCTeX Talk
Discussions on TeX, LaTeX, fonts, and typesetting
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

MikTeX YAP viewer cannot find cmb10

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    PCTeX Talk Forum Index -> MathTime Pro II Beta
View previous topic :: View next topic  
Author Message
murray



Joined: 07 Feb 2006
Posts: 47
Location: Amherst, MA, USA

PostPosted: Sun Mar 05, 2006 7:13 pm    Post subject: MikTeX YAP viewer cannot find cmb10 Reply with quote

I TeX'ed the distributed Test_latex.tex source distributed with mtpro2.
Just two problems -- (1) the \usepackage line needs to be changed to refer to mtpro2 rather than mtpro and (2) the symbols \varGamma and \varOmega are not defined -- but otherwise the TeX'ing went OK.

However, the YAP viewer could not load the requisite cmb10. See the YAP details in "cmb10 Logbook" below.

Here's what I did for installation:
I unzipped the mtpsfont.zip to MiKTex's texmf tree (actually, had to unzip to a temporary directory, then copy, since the top directory in the zip was texmf rather than localtexmf).

I edited localtexmf\web2c\updmap.cfg so as to insert at the end the line:
Map mtpro2.map #localtexmf\dvips\mtpro\mtpro2.map
then I ran mkfntmap (as MiKTeX does not seem to provide a updmap command).
Then I refreshed the MiKTeX filename database.

%%%% cmb10 Logbook %%%%%
Making PK font:
d:\WP\texmf\miktex\bin\makepk.exe --verbose cmb10 600 600 magstep(0.0) ljfour
Trying to make PK font "cmb10" (at 600 DPI)...
Creating "cmb10.pk"...
"mf" \mode:=ljfour; \mag:=magstep(0.0);nonstopmode;input cmb10
This is METAFONT, Version 2.71828 (MiKTeX 2.4)

(d:\WP\texmf\fonts\source\public\cm\cmb10.mf
(d:\WP\texmf\fonts\source\public\cm\cmbase.mf)
(d:\WP\texmf\fonts\source\public\cm\roman.mf
! Missing `:' has been inserted
! This can't happen (copy).
mode_param->if.unknown.mode_guard_(EXPR5000)
:(EXPR5000):=(EXPR1);mode_guard_...

ljfour_->mode_param(pixels_per_inch,600)
;mode_param(blacker,0.25);mode_param...
<scantokens> ljfour_

<to be read again>
;
mode_setup->...nput "&mode)else:mode_name[mode]fi;
if.unknown.mag:mag=1;fi.if...
l.12 mode_setup
; font_setup;
Transcript written on cmb10.log.
METAFONT failed for some reason
makepk: METAFONT failed on "cmb10".


Loading 'cmr10' instead.
Back to top
View user's profile Send private message Visit poster's website
WaS



Joined: 07 Feb 2006
Posts: 27
Location: Erlangen, Germany

PostPosted: Mon Mar 06, 2006 5:11 am    Post subject: Re: MikTeX YAP viewer cannot find cmb10 Reply with quote

murray wrote:
However, the YAP viewer could not load the requisite cmb10. See the YAP details in "cmb10 Logbook" below.


This is a well-known bug in MikTeX.
(Google for the error message "This can't happen" in comp.text.tex.)
Fix: update the format files (miktex->options.)
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    PCTeX Talk Forum Index -> MathTime Pro II Beta All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group