PCTeX Talk Forum Index PCTeX Talk
Discussions on TeX, LaTeX, fonts, and typesetting
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Does PCTeX have proper e-TeX support?

 
Post new topic   Reply to topic    PCTeX Talk Forum Index -> PCTeX 6
View previous topic :: View next topic  
Author Message
mwrenfro



Joined: 11 Mar 2011
Posts: 1

PostPosted: Fri Mar 11, 2011 2:55 pm    Post subject: Does PCTeX have proper e-TeX support? Reply with quote

(Cross-posted from LaTeX Community)

In trying to use the etoolbox package with PCTeX v6 (6.1, Build Fri Apr 16 13:29:46 2010), it looks like either PCTeX doesn't have e-TeX support, or etoolbox is checking for that support incorrectly. Since PCTeX didn't include etoolbox, or know how to get it from CTAN (or else I don't know how to fix it), I copied etoolbox.sty and etoolbox.def v2.1 from a TeX Live 2010 install into the same folder as the MWE below:

Code:
\documentclass{article}
\usepackage{etoolbox}
\begin{document}
Hello, world.
\end{document}


Building this with PCTeX returns "! Package etoolbox Error: Not running under e-TeX." while building it with TeX Live 2010 works fine. Any ideas on how to narrow down the source of the problem?
Back to top
View user's profile Send private message
PTIForAdmin



Joined: 06 Oct 2005
Posts: 84
Location: San Francisco, CA

PostPosted: Mon Mar 14, 2011 6:19 am    Post subject: Re: Does PCTeX have proper e-TeX support? Reply with quote

mwrenfro wrote:
(Cross-posted from LaTeX Community)

In trying to use the etoolbox package with PCTeX v6 (6.1, Build Fri Apr 16 13:29:46 2010), it looks like either PCTeX doesn't have e-TeX support, or etoolbox is checking for that support incorrectly. Since PCTeX didn't include etoolbox, or know how to get it from CTAN (or else I don't know how to fix it), I copied etoolbox.sty and etoolbox.def v2.1 from a TeX Live 2010 install into the same folder as the MWE below:

Code:
\documentclass{article}
\usepackage{etoolbox}
\begin{document}
Hello, world.
\end{document}


Building this with PCTeX returns "! Package etoolbox Error: Not running under e-TeX." while building it with TeX Live 2010 works fine. Any ideas on how to narrow down the source of the problem?


To use e-TeX's extended mode, go to PCTeX's Typeset menu, select INITeX, select LaTeX, add an asterisk to the beginning of the macro file name (i.e. "*latex.ltx"), and click INITeX.

Now when you typeset with LaTeX, it will use e-TeX's extended mode.
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    PCTeX Talk Forum Index -> PCTeX 6 All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group