PCTeX Talk Forum Index PCTeX Talk
Discussions on TeX, LaTeX, fonts, and typesetting
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Y&Y TeX vs. MiKTeX with MathTimePro2 fonts

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    PCTeX Talk Forum Index -> MathTime Pro II Beta
View previous topic :: View next topic  
Author Message
murray



Joined: 07 Feb 2006
Posts: 47
Location: Amherst, MA, USA

PostPosted: Wed Mar 15, 2006 10:53 pm    Post subject: Y&Y TeX vs. MiKTeX with MathTimePro2 fonts Reply with quote

I used updated fonts just prior to posting of 0.98.

Initially I had different page breaks with a test document of my own in the two TeX systems. but that seems to have disappeared once I updated geometry.sty in Y&Y to the same version I use with MiKTeX.

There are two other peculiarities, indirectly related to the fonts:

1. With Y&Y, when mtpro2.sty is loaded, I get messages that \vec is already defined, and then ditto for \grave, \acute, \check, \breve, \bar, \hat, \dot, \tilde, \ddot. Perhaps this is due to different versions of amsmath.sty?

2. In Y&Y, I must include

\usepackage[T1]{fontenc}

for otherwise I get message:

OT1/ptm/m/n/10.95=ptm7t at 10.95pt not loadable:
Metric (TFM) file not found

I am clearly using different psnfss package files with Y&Y than with MiKTeX. I tried updating the Y&Y versions to be the same as those for MiKTeX, but then all hell breaks loose over encodings -- with Y&Y expecting to find TeXnAnsi encodings and not finding them. (It may be that in Y&Y I have to update tfm's for Times, too. But I am loathe to mess further with Y&Y with respect to a working font configuration.)
Back to top
View user's profile Send private message Visit poster's website
WaS



Joined: 07 Feb 2006
Posts: 27
Location: Erlangen, Germany

PostPosted: Thu Mar 16, 2006 3:47 am    Post subject: Reply with quote

please, send me <w.a.schmidt@gmx.net> your test document and the
log files that would result with and without \usepackage[T1]{fontenc}

TIA
Walter
Back to top
View user's profile Send private message Visit poster's website
WaS



Joined: 07 Feb 2006
Posts: 27
Location: Erlangen, Germany

PostPosted: Fri Mar 17, 2006 9:27 am    Post subject: Reply with quote

Preliminary anwers:

1) Using T1 encoding with Times cannot work on Y&Y-TeX.
Y&Y-TeX supports Times and other fonts from the non-TeX world
only with LY1 encoding.

2) Updating psnfss on Y&Y-TeX is pointless. The psnfsss collection
supports the Base35 fonts with OT1 and T1/TS1 encoding, which
does not work on Y&Y-TeX; see above.

3) Loading fontenc should not be necessary at all, but
I do not yet understand why you get the error re. OT1/ptm.
Does it help to issue \usepackage[LY1]{fontenc} before loading
mtpro2?

4) The errors re. \vec etc. may be due to an obsolete amsmath.sty,
as compared with MikTeX. Please, run a minimal test document
that does not use amsmath to check this.

More info on Sunday.
Back to top
View user's profile Send private message Visit poster's website
murray



Joined: 07 Feb 2006
Posts: 47
Location: Amherst, MA, USA

PostPosted: Fri Mar 17, 2006 7:49 pm    Post subject: Your answers identified the problems & solutions! Reply with quote

WaS wrote:
Preliminary anwers:

1) Using T1 encoding with Times cannot work on Y&Y-TeX....

2) Updating psnfss on Y&Y-TeX is pointless....

3) Loading fontenc should not be necessary at all, but
I do not yet understand why you get the error re. OT1/ptm.
Does it help to issue \usepackage[LY1]{fontenc} before loading
mtpro2?

4) The errors re. \vec etc. may be due to an obsolete amsmath.sty,
as compared with MikTeX. Please, run a minimal test document
that does not use amsmath to check this.


Re 3): Yes, \usepackage[LY1]{fontenc} in my test documen avoides he error about OT1.

5) Yes, the error about \vec, etc., was due to an obsolete amsmath.sty. Refreshing the amsmath files fixed this.

Thank you!
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    PCTeX Talk Forum Index -> MathTime Pro II Beta All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group